IRC - Biblioteka.sk

Panta Rhei Doprava Zadarmo


A | B | C | D | E | F | G | H | CH | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9

IRC
Balík internetových protokolov
Aplikačná vrstva
HTTP · HTTPS · FTP · SSH · IMAP · SMTP · NNTP · IRC · SNMP · SIP · RTP · NFS a iné
Transportná vrstva
TCP, UDP, SCTP, DCCP a iné
Sieťová vrstva
IPv4, IPv6, ARP a iné
Linková vrstva
Ethernet, Wi-Fi, Token ring, FDDI a iné
Fyzická vrstva
RS-232, EIA-422, RS-449, EIA-485 a iné
z • d • u
Schéma siete IRC s klientmi (zelená), botmi (modrá) a bouncermi (oranžová)
Screenshot programu Kvirc pod Linuxom

Internet Relay Chat (skratka IRC) je protokol určený na okamžitú textovú komunikáciu. Je založený na klient-server architektúre. IRC je určené hlavne na komunikáciu skupín (viacerí-viacerým) v diskusných fórach zvaných channels (kanály), ale tiež umožňuje komunikáciu jedného s jedným alebo prenos súborov cez Direct Client-to-Client (DCC). IRC klient je počítačový program pomocou ktorého sa užívateľ pripája k IRC serveru a komunikuje s ostatnými užívateľmi.

IRC bolo jednou z prvých možností komunikácie v reálnom čase cez internet. Vo svojej dobe spájala významnú časť internetových užívateľov. IRC tak čiastočne stojí pri zrode „internetového chatovania“.

IRC vytvoril Jarkko Oikarinen (nickname "WiZ") neskoro v auguste 1988 ako náhradu za program zvaný MUT (MultiUser Talk) na Fínskom BBS zvanom OuluBox. Oikarinen sa inšpiroval Bitnet Relay Chatom na Bitnet networku.

IRC získal význam, keď bol použitý na podanie správy o pokuse o prevrat v Sovietskom zväze v roku 1991 v priebehu utíchnutia masmédii. Neskôr bol použitý v podobnej situácii v Kuvajte počas Irackej invázie.[chýba zdroj

Technické informácie

IRC je otvorený protokol aplikačnej vrstvy, používa TCP a voliteľne môže používať TLS. IRC server sa môže pripojiť na iné IRC servery a tak môže rozšíriť IRC sieť. Používatelia pristupujú na IRC pripojením klienta na server. Existuje mnoho implementácií pre klienta, napríklad mIRC, HexChat (odvodený of XChat) a irssi, a servera, napríklad pôvodný IRCd. Väčšina IRC serverov nevyžaduje prihlásenie používateľov, ale používateľ si musí nastaviť prezývku (nickname) pred tým, ako sa pripojí na server.

IRC je protokol, ktorý používa čisto textový protokol, čo znamená, že je možné (hoci nepohodlné) používať IRC cez obyčajný klient pracujúci s prúdom bajtov, ako napríklad netcat alebo telnet. Protokol používal len jemne modifikovanú verziu ASCII a pôvodne neposkytoval žiadnu podporu pre texty zo znakmi mimo ASCII. Nakoniec sa začali používať dosť rozdielne a nekompatibilné kódovania znakov (ako napríklad ISO 8859-1 a UTF-8).

Pretože väčšina implementácií IRC používa acyklický graf ako ich model na pripojenie, neexistuje tu redundancia pri spojení medzi servermi a pri poruche servera môže nastať netsplit.

Vývoj

Všetky klient-server IRC protokoly, ktoré sa používajú dnes sú odvodené z protokolu implementovaného v irc2.8 verzie IRC2serveru a dokumentované v RFC 1459. Odkedy bola publikovaná RFC 1459, boli implementované nové funkcie v irc2.10, ktoré viedli k publikovaniu opravených protokolových dokumentov; RFC 2810, RFC 2811, RFC 2812 a RFC 2813, avšak zmeny týchto protokolov neboli všeobecne prijaté medzi ostatné implementácie. IRC 2.10 je najviac používané na sieti IRCnet. IRC protokol bol rozšírený Microsoftom v roku 1998 jeho IRCX protokolom, ktorý rieši mnoho tradičných problémov, ktorým čelila celá generácia IRC sietí, spolu s niektorými funkciami, o ktorých si väčšina používateľov myslela, že „predbieha svoju dobu“. Hoci bolo publikovaných mnoho noriem IRC protokolov, neexistuje žiadna oficiálna norma, takže protokol ostáva dynamický. V skutočnosti žiaden klient a veľmi málo serverov sa striktne odvoláva na vyššie uvedené RFC.

Kým sú si protokoly klient-server aspoň funkčne podobné, protokoly server-server sa značne odlišujú (TS5, P10 a ND/CD sú osobitne značne používané a nekompatibilné serverové protokoly) a spôsobujú, že je veľmi komplikované prepojiť dve osobitné implementácie IRC servera. Existujú servery používané ako „mosty“, ktoré pomáhajú spojiť, napríklad, servery 2.10 so servermi TS5), ale tieto často sprevádzajú obmedzenia, ktoré časti každého protokolu majú byť použité a nie sú príliš používané v praxi.

V prvých formách IRC nemalo toľko vlastností, aké má dnes, napr. mená kanálov a operátori na kanáloch. Kanály boli očíslované -- napríklad kanál 4 a kanál 57 -- a téma kanála popisovala druh konverzácie, ktorá sa práve konala na kanále. Odtiaľ pochádza pamiatka, že pri pripojení sa na kanál 0 je klient prinútený, aby opustil všetky kanály, na ktorých práve je: „KANÁL 0“ je pôvodný príkaz pre opustenie aktuálneho kanála.

Prvá hlavná zmena v IRC verzie 2.5 bola pridanie pomenovaných kanálov -- „+kanály“, tieto boli neskôr vo verzii 2.7 vymenené za „#kanály“, numerické (číselné) kanály boli úplne odstránené a bol implementovaný ban (zákaz prístupu) na kanál. irc2.8 pridalo „&kanály“, ktoré existovali len na aktuálnom (lokálnom) serveri a nie na celkovej sieti IRC a „!kanály“, ktoré tieto boli teoreticky bezpečné proti útoku, kde mohol používateľ exploitnúť (zneužiť dieru v systéme) kanál pri netsplite, a je to základné vydanie, od ktorého sú odvodené skoro všetky implementácie.

Významné verzie založené na 2.8 obsahujú:

  • 2.8.21+CS, vyvinutý Comstudom
  • 2.8+th, Tanerov patchset, ktorý sa neskôr stal
  • 2.8/hybrid, originálne vyvinutý Jonom Luskym (Rodder) a Dianou Bruceovou (Dianora), ktorí sa neskôr spojili do veľkeho vývojového tímu.
  • 2.9, 2.10, 2.11, ... pokračovanie vývoja originálneho kódu jadra, hlavne pre použitie pre siete IRC. Táto vývojová línia vyprodukovala 4 IRC RFC vydané po RFC 1459, ktoré výhradne dokumentujú tento serverový protokol.

2.8.21+CS a 2.8/hybrid sa naďalej používa na EFnete s ircd-ratboxom (odnož z 2.8/hybrid), ktorý bol v roku 2004 najobľúbenejší.

Undernetový IRC server, ircu, je jeden z mála serverov, ktorý nebol odvodený z irc2.8, ktorý je založený na originálnom ircd; bol odvodený z kódu irc2.7.

Mnoho moderných IRC serverov bolo napísaných odznova, ako csircd (tiež z Comstud), ConferenceRoom, Microsoft Exchange Chat Service a IRCPlus/IRCXPro.

Kanály

Základný komunikačný prostriedok na nadviazanie IRC relácii je kanál. Všetky kanály na serveri je možné zobraziť príkazom /list.

Na kanály sa môžu používatelia pripojiť a potom posielať správy, ktoré sú potom prenášané k ostatným používateľom na tom istom kanáli. Kanály, ktoré sú dostupné po celej sieti IRC, majú prefix „#“, zatiaľ čo tie, čo sú na lokálnom serveri, môžu použiť „&“. Medzi ostatné (neštandardné) typy kanálov patria „+“ kanály-"bez módov", kanály bez operátorov a kanály „!“, forma timestamped (s časovou pečiatkou) kanálu na obyčajne non-timestamped (bez časovej pečiatky) sietiach.

Módy

Používatelia aj kanály môžu mať módy, ktoré predstavujú ich atribúty. Módy sú reprezentované jednopísmenovou skratkou, takže sa dajú jednoducho za sebou zreťaziť. Napríklad používateľský mód „i“ znamená neviditeľný (Nemôžete povedať, či daný neviditeľný používateľ je na kanáli, ak nie ste na tom istom kanáli). Pri móde záleží na tom, či je použitý pri kanáli alebo pri používateľovi.

Módy môžu mať tiež parametre, napríklad mód k, ktorý určuje kľúč ku kanálu.

Nastavovanie módov prebieha pomocou príkazu mode. Pre pridávanie resp. uberanie módu sa používajú symboly + resp. -.

Štandardné módy (RFC 1459)

Užívateľské módy
Znak Symbol Popis
i neviditeľný — nemôžete ho vidieť, ak neviete presný nick alebo nie ste na rovnakom kanáli
s príjma správy od serveru
w príjma wallops
o užívateľ je IRC operátor (ircop)
Módy na kanáli
Znak Symbol Parameter Popis
o @ nick používateľa, ktorý má byť ovplyvnený operátor kanálu – môže meniť kanálové módy a vyhadzovať ľudí z kanálu
s tajný kanál – nie je uvedený v zozname kanálov alebo v whois (okrem používateľov, ktorí už na tom kanáli sú)
p privátny kanál – v zozname kanálov ako "prv" (podľa RFC 1459)
n užívatelia, ktorí nie sú na kanáli, do neho nemôžu písať
m kanál je moderovaný – len používatelia, ktorí majú hlas (+v) môžu písať správy
i len na pozvanie – používateľ sa môže pripojiť len ak ho operátor kanálu pozve
t tému môže meniť len operátor kanálu
l limit limituje počet používateľov na kanáli
b ban maska (nick!user@host s povolenými rozsahmi) zablokuje používateľovi prístup na kanál
v + nick používateľa, ktorý má byť ovplyvnený dá používateľovi hlas (voice) – viz. +m hore
k kľúč nastaví na kanál kľúč (heslo) – len používatelia, ktorí ho poznajú, môžu vstúpiť na kanál

Klienti

mIRC je vo všeobecnosti považovaný za najpopulárnejšieho IRC klienta pre Windows. S príchodom klientov ako napríklad Bersirc, KVIrc, Trillian, Miranda IM a X-Chat začína mať väčšiu konkurenciu. Veľa ľudí však stále používa mIRC hlavne kvôli existencii mnohých skriptov pre tohto klienta.

ircII je jedným z prvých Unixových irc klientov, ale jeho používateľská základňa sa zmenšila s príchodom klientov ako ircII-EPIC, BitchX, irssi, X-Chat, atď. V prostredí KDE existuje klient s názvom Konversation.

Najrozšírenejšie klienty pre Mac OS X sú Ircle a Colloguy.

Na OS X je možné spustiť väčšinu Unixových klientov. Nedávno vyšla špeciálna verzia X-Chatu pre OS X systémy Aqua[1].

ChatZilla je Mozilla Firefox IRC klient.

Opera má taktiež zabudovaného IRC klienta.

Začínajúcim používateľom sa môžu mIRC a iné klienty zdať zbytočne veľkí a komplexní. Noví používatelia môžu uprednostniť instant messenger klientov ako Miranda IM alebo Trillian, ktorí poskytujú známejšie rozhranie pre IRC.

Framework vytvorený na začlenenie IRC do rôznych aplikácií ako hry sa nazýva LibIRC, hoci je stále vo vývoji.

Boty

Existuje veľké množstvo automatizovaných klientov, nazývaných boty. Prvého bota napísal Greg Lindahl a fungoval ako multiplayerová verzia hry Wumpus, ale moderné boty sa využívajú najmä na prideľovanie operátorských privilégií (kontrolovanie kanála a rýchle reagovanie v prípade porušovania jeho pravidiel), na otravovanie používateľov (zaplavovaním používateľov rôznymi správami), na odpovedanie opakovaných otázok používateľov, na poskytovanie pomoci, keď nie sú prítomní operátori kanála alebo slúžia ako stále kontaktné body pre výmenu informácií (odkazovač, prenos súborov, atď.). V súčasnosti najpopulárnejšie boty sú Eggdrop a EnergyMech.

Moderné IRC služby sú implementované využitím botov. Boty sú dôležitou súčasťou správy kanálu. Využívajú sa na blokovanie používateľov, udržiavanie operátorov, udržiavanie témy kanálu atď.

Bouncery

Program, ktorý beží na serveri ako daemon a funguje ako perzistentný proxy server, sa nazýva bouncer. Jeho úloha je zabezpečiť spojenie na IRC server, tváriac sa ako spojovací článok medzi serverom a pripájajúcim sa klientom. Ak klient stratí sieťovú konektivitu, bouncer archivuje všetky správy pre neskoršie doručenie. Najpopulárnejšie bouncery sú muh Archivované 2004-10-09 na Wayback Machine, psyBNC, shroudBNC a ZNC Archivované 2010-12-07 na Wayback Machine. Muh je určený len pre jedného používateľa, zatiaľ čo psyBNC, shroudBNC a ZNC podporujú viac používateľov. shroudBNC a ZNC ponúka navyše správu používateľských účtov cez webové rozhranie.

Referencie

  1. ↑ Archivovaná kópia . . Dostupné online. Archivované 2008-03-26 z originálu.

Pozri aj

Iné projekty

Externé odkazy

Zdroj:
Text je dostupný za podmienok Creative Commons Attribution/Share-Alike License 3.0 Unported; prípadne za ďalších podmienok. Podrobnejšie informácie nájdete na stránke Podmienky použitia.
Zdroj: Wikipedia.org - čítajte viac o IRC

Írán
Úmrtí v roce 2023
Únor
Ústřední výbor Komunistické strany Československa
Útok Hamásu na Izrael (říjen 2023)
Čadca
Časová osa ruské invaze na Ukrajinu (2023)
Češi
Čeština
Čechizace
Červen
Červenec
Česká Wikipedie
České knížectví
České království
České státní právo
České země
Český král
Český rozhlas
Český státní svátek
Český Těšín
Česko
Československo
Československo-polské pohraniční spory
Československo-polský spor o Těšínsko
Říjen
Římská mytologie
Římský kalendář
Římský konzul
Ševat
Šlonzáci
Šumavská župa
Švédsko
Židé
Židovský kalendář
1. leden
1. listopad
10. leden
10. století
1054
11. říjen
11. leden
11. století
12. říjen
12. leden
1281
1290
13. leden
13. století
1327
1335
1339
14. leden
15. červen
15. leden
15. poledník východní délky
1526
153 př. n. l.
1573
1574
16. leden
1620
1653
17. leden
18. únor
18. leden
1813
1848
1867
1893
19. leden
19. století
1908
1910
1911
1912
1918
1919
1920
1921
1923
1924
1930
1934
1937
1938
1939
1958
1973
2. říjen
2. leden
20. leden
20. století
2024
21. říjen
21. leden
21. září
22. leden
23. leden
24. únor
24. leden
24. srpen
25. leden
26. březen
26. leden
27. březen
27. leden
28. červenec
28. leden
29. říjen
29. duben
29. leden
3. únor
3. říjen
3. leden
30. říjen
30. leden
30. září
31. červenec
31. říjen
31. leden
4. říjen
4. leden
45 př. n. l.
5. říjen
5. leden
50. rovnoběžka severní šířky
6. říjen
6. leden
7. říjen
7. leden
7TP
8. říjen
8. leden
8. století
9. březen
9. leden
Adolf Hitler
Afghánistán
Agneta Anderssonová
Alžběta Lukrécie Těšínská
Alexander Dubček
Alexander Fleming
Alkmaar
Andrej Bělocvětov
Angličtina
Anne L'Huillierová
Antibiotikum
Antonín Novotný
Asimilace (sociologie)
Autoritní kontrola
Břetislav I.
Březen
Bavorsko
Beno Budar
Betlémská hvězda
Bezpilotní letadlo
Boleslav Chrabrý
Brno
Brzice
Charita Česká republika
Charkovská oblast
China Mobile
Chlum u Třeboně
Commons:Featured pictures/cs
Covid-19
Dýmová hora
Daniel Anýž
Den obnovy samostatného českého státu
Diskuse k Wikipedii:Žádost o práva správce#Návrh na úpravu pravidel o neaktivitÄ›
Diskuse k Wikipedii:Délka článku#Nutnost úprav
Diskuse k Wikipedii:Rychlé smazání#Návrh na doplnÄ›ní dalšího bodu
Diskuse k Wikipedii:Vzhled a styl#ZávÄ›rečné sekce: sjednocení variant struktury v doporučení
Drew Weissman
Druhá Polská republika
Druhá světová válka
Druhý vatikánský koncil
Duben
Edvard Beneš
Elektron
Encyklopedie
Epifanie
Ernst Boris Chain
Evropa
Exkláva
Ferenc Krausz
Frýdek
Francie
Francis Lee
Gemeinsame Normdatei
Generální tajemník ÚV KSČ
Godesberské memorandum
Gotická architektura v Česku
Gregoriánský kalendář
Guido del Mestri
Habsburkové
Halič
Hamás
Havlíčkův Brod
Herát (provincie)
Hlavní strana
Hořičky
Homs
Howard Walter Florey
Hrčava
Hubíles
Huntířov (okres Děčín)
Husitství
International Standard Book Number
Internet Archive
Invaze do Polska (1939)
Invaze vojsk Varšavské smlouvy do Československa
IRC
IROZHLAS
Izrael
Ján Jakubík
Józef Beck
Józef Londzin
Józef Piłsudski
Jablunkovský incident
Janus
Jan Křtitel
Jan Lucemburský
Jan Michejda
Jan Palach
Javořinka
Javorník (okres Jeseník)
Ježíš Kristus
Jižní polokoule
Jidiš
Jihlava
Jomkipurská válka
Jon Fosse
Jordán
Josef Šnejdárek
Josef Koždoň
Joseph Goebbels
Juliánský kalendář
Julius Caesar
Kříž
Kalendářní měsíc
Kanonické právo
Karel Hartl
Karviná
Katalin Karikóová
Kategorie:Údržba:Články k ověření
Kategorie:Údržba:Články porušující NPOV
Kategorie:Čas
Kategorie:Články podle témat
Kategorie:Život
Kategorie:Dorozumívání
Kategorie:Geografie
Kategorie:Historie
Kategorie:Hlavní kategorie
Kategorie:Informace
Kategorie:Kultura
Kategorie:Lidé
Kategorie:Matematika
Kategorie:Příroda
Kategorie:Politika
Kategorie:Právo
Kategorie:Rekordy
Kategorie:Seznamy
Kategorie:Společnost
Kategorie:Sport
Kategorie:Technika
Kategorie:Umění
Kategorie:Věda
Kategorie:Vojenství
Kategorie:Vzdělávání
Kategorie:Wikipedie
Kategorie:Wikipedie:Doporučení
Kategorie:Wikipedie:Navrhovaná pravidla
Kategorie:Wikipedie:Neschválené návrhy
Kategorie:Wikipedie:Pravidla
Kategorie:Wikipedie:Pravidla v hlasování
Kategorie:Wikipedie:Závazná pravidla
Kategorie:Zdravotnictví
Kazimír III. Veliký
Kevin McCarthy
Klasifikace sinic#Nová fylogenetická systematika
Klementinum
Klub českých turistů
Košicko-bohumínská dráha
Kodifikace (právo)
Konference velvyslanců
Kongresové Polsko
Konstantin von Neurath
Kostel svaté Ludmily (Vinohrady)
Kozoroh (znamení)
Královec (okres Trutnov)
Královské Vinohrady
Krakov
Květen
Kvantová tečka
Kyjev
Lékař
Léno
Latina
Led
Leden
Lednová stávka v Rakousko-Uhersku
Lednové povstání
Leon Malhomme
Letiště Berlín-Tempelhof
Listopad
Liturgické mezidobí
Liturgický rok
Lunární kalendář
Luteránství
Měšek I. Těšínský
Maďaři
Maďarsko
Maršál
Maria (matka Ježíšova)
Marina Ovsjannikovová
Max Wolf
Mezinárodní den památky obětí holocaustu
Mikrobiologie
Milhostov
Ministr zahraničí
Mirko Škampa
Mistrovství světa v ragby 2023
Mnichovská dohoda
Monofyletismus
Mor
Morava
Moravská Ostrava
Moungi Bawendi
Nápověda:Úvod
Nápověda:Úvod pro nováčky
Nápověda:Jak editovat stránku
Nápověda:Jak vytvořit článek
Nápověda:Obsah
Nápověda:Pravidla
Národní knihovna České republiky
Němčina
Němci
Německá jižní Morava
Německé Čechy
Německé Rakousko
Německo-polský pakt o neútočení
Nacistické Německo
Nadace Wikimedia
Napoleonské války
Narghís Mohammadiová
Nobelova cena za chemii
Nobelova cena za fyziku
Nobelova cena za fyziologii a lékařství
Nobelova cena za literaturu
Nobelova cena za mír
Norsko
Nový rok
Noviny Těšínské
Nukleosid
Numa Pompilius
Občanská obrana
Obřezání Páně
Odúmrť
Oktáv Narození Páně
Olše (řeka)
Oldřich Pelčák
Olomouc
Operace Sochor
Opolské knížectví
Orlová
Osmdesátiletá válka
Ostrava
Ostravská pánev
Osvětimské knížectví
Přebohaté hodinky vévody z Berry
Předseda Sněmovny reprezentantů Spojených států amerických
Přemek Ratibořský
Přemyslovci
Přestupný rok
Paříž
Palestinská území
Palestinský islámský džihád
Patricia Janečková
Penicilin
Piastovci
Pitovití
Plebiscit
Plebiscit na Těšínsku
Podkarpatská Rus
Poláci
Polština
Polsko
Polsko-sovětská válka
Polsko-ukrajinská válka
Portál:Aktuality
Portál:Doprava
Portál:Geografie
Portál:Historie
Portál:Kultura
Portál:Lidé
Portál:Náboženství
Portál:Obsah
Portál:Příroda
Portál:Sport
Povstání spartakovců
Pražské jaro
Praha
Prosinec
Protektorát Čechy a Morava
Protestantismus
Protesty proti ruské invazi na Ukrajinu
Pruchná
Pruské Slezsko
První kanál (Rusko)
První republika
První světová válka
Q108#identifiers
Q108#identifiers|Editovat na Wikidatech
Q1640496#identifiers
Q1640496#identifiers|Editovat na Wikidatech
Rýnský spolek
Růžová (okres Děčín)
Rakouské císařství
Rakouské Slezsko
Rakousko-Uhersko
Ratibořské knížectví
Republikánská strana (USA)
Revoluce v roce 1848
Richard Salzmann
RNA vakcína
Rok
Ron Hextall
Rozsochatec
Rudolf Žáček
Runcimanova mise
Ruská invaze na Ukrajinu
Ruské impérium
Rusko
Sýrie
Sčítání lidu
Samostatná operační skupina „Slezsko“
Sedmidenní válka
Sejm
Severní polokoule
Seznam historických výročí
Seznam nositelů Nobelovy ceny za fyziologii a lékařství
Seznam opolských knížat
Seznam smírčích křížů v Jihočeském kraji
Seznam smírčích křížů v Praze
Seznam těšínských knížat
Slezská knížectví
Slezské písně
Slezský odboj
Slezsko
Slované
Slovenština
Slovenská republika (1939–1945)
Slovensko
Slunce
Slunovrat
Smírčí kříž
Sněmovna reprezentantů Spojených států amerických
Soubor:2021 Hraniční kámen na Těšínsku (1920).jpg
Soubor:Anticzech agitation.jpg
Soubor:Antipolish agitation aimed at Teschen Silesians.jpg
Soubor:Bomb attack Orlová.jpg
Soubor:Bundesarchiv Bild 183-B0527-0001-293, Warschau, Empfang Goebbels bei Marschall Pilsudski.jpg
Soubor:Cieszyn Piast dynasty COA.png
Soubor:Czech military organisation.jpg
Soubor:Decree on Official Language on Annexed Territory.jpg
Soubor:Der Aufbau der Republik Deutschösterreich.png
Soubor:Duchy of Silesia 1912.jpg
Soubor:Ilustrowany Kuryer Codzienny 4 X 1938.jpg
Soubor:Křížový kámen u Rozsochatce.jpg
Soubor:Karwina1939.jpg
Soubor:Koždoň's plebiscite workers.jpg
Soubor:Královec, smírčí kříž.JPG
Soubor:Les Très Riches Heures du duc de Berry Janvier.jpg
Soubor:Map of plebiscite area.jpg
Soubor:Náměstí Míru sv. Ludmila.jpg
Soubor:Nasz Kocur Numer wielkanocny 1920.jpg
Soubor:Poland1937linguistic.jpg
Soubor:Polish Army capturing Zaolzie in 1938.PNG
Soubor:Polská armáda vjíždí do Těšína - 1938.jpg
Soubor:POL Pruchna Krzyż pamiątkowy 1.jpg
Soubor:Portal.svg
Soubor:Rakousko-Uhersko 1910.PNG
Soubor:Slask Zaolzianski.jpg
Soubor:Smířčí kříž v obci Hubiles.jpg
Soubor:Smírčí kříže u Milhostova.jpg
Soubor:Smírčí kříž u Hořiček.jpg
Soubor:Smírčí kříž u silnice z Růžové do Nové Olešky.jpg
Soubor:Smirci-kriz-magyarcsanad-magyarorszag.jpg
Soubor:Synthetic Production of Penicillin TR1468.jpg
Soubor:Těšín Silesia Czech flyer.jpg
Soubor:Typhoon Tip and Typhoon Sarah (1997).png
Soubor:Veverská Bítýška - smírčí kámen.jpeg
Soubor:Zřízení zemské Knížetství Těšínského 1574.jpg
Soubor:Zaolzie.jpg
Souhvězdí
Souhvězdí Kozoroha
Souhvězdí Střelce
Spa
Speciální:Co odkazuje na/Šablona:Celkově zpochybněno
Speciální:Co odkazuje na/Šablona:Přesnost
Speciální:Kategorie
Speciální:Nové stránky
Speciální:Poslední změny
Speciální:Statistika
Speciální:Zdroje knih/80-7203-157-0
Speciální:Zdroje knih/978-80-86660-37-0
Spojené státy americké
Srpen
Stát Palestina
Středoevropský čas
Středověk
Stanisław Zahradnik
Sudetenland (provincie, 1918)
Sudetoněmecká strana
Suezský průplav
Svátek Křtu Páně
Svědomí
Svatba v Káně
Těšín
Těšínské knížectví
Těšínské nářečí
Těšínsko
Tříkrálová sbírka
Tři králové
Tadeusz Reger
Tajfun Tip
Tank
Taxon
Tevet
Trenčín
Trenčínská smlouva
Trojdohoda
Tropická cyklóna
Uhlí
Ukrajina
Václav III. Adam Těšínský
Vánoce
Výmarská republika
Varšava
Velkomoravská říše
Veverská Bítýška
Vilém Mandlík
Vladislav I. Opolský
Vlk
Vodnář (znamení)
Vyhlášení války
Vykupitel
Vyslanec
Władysław Bortnowski
Wiki
Wikicitáty:Hlavní strana
Wikidata:Hlavní strana
Wikifunctions:Main Page
Wikiknihy:Hlavní strana
Wikimedia Česká republika
Wikimedia Commons
Wikipedie
Wikipedie:Účast v hlasování
Wikipedie:Údržba
Wikipedie:Časté chyby
Wikipedie:Často kladené otázky
Wikipedie:Článek týdne
Wikipedie:Článek týdne/2023
Wikipedie:Žádné open proxy
Wikipedie:Žádný vlastní výzkum
Wikipedie:Žádost o arbitráž
Wikipedie:Žádost o komentář
Wikipedie:Žádost o komentář/(Ne)závislost zdrojů
Wikipedie:Žádost o komentář/Názvy článků událostí
Wikipedie:Žádost o komentář/Osobní urážky
Wikipedie:Žádost o komentář/Používání zkrácených citací
Wikipedie:Žádost o komentář/Velké jazykové modely – komplexní diskuse
Wikipedie:Žádost o opatření
Wikipedie:Žádost o opatření/Foxx70 a IP editor
Wikipedie:Žádost o práva správce
Wikipedie:Blokování
Wikipedie:Bot
Wikipedie:Bot/Žádosti o provedení práce
Wikipedie:Brno
Wikipedie:Chybějící stránky
Wikipedie:Citování Wikipedie
Wikipedie:Co Wikipedie není
Wikipedie:Diskuse o smazání
Wikipedie:Diskuse o smazání/1. FK Spartak Jablunkov
Wikipedie:Diskuse o smazání/Polyetheretherketony
Wikipedie:Diskuse o smazání/Sociální konstruktivismus
Wikipedie:Diskuse o smazání/Vzduchová trampolína
Wikipedie:Dobré články
Wikipedie:Dobré články#Portály
Wikipedie:Hlasování
Wikipedie:IRC
Wikipedie:Kontakt
Wikipedie:Kronika
Wikipedie:Nástěnka správců
Wikipedie:Nejlepší články
Wikipedie:Nezaujatý úhel pohledu
Wikipedie:Nominace nejlepších článků
Wikipedie:Nominace nejlepších článků/Kroužkovci
Wikipedie:Obrázek týdne
Wikipedie:Obrázek týdne/2023
Wikipedie:Ohlasy v médiích
Wikipedie:Ověřitelnost
Wikipedie:Patroláři a revertéři
Wikipedie:Požadované články
Wikipedie:Požadované obrázky
Wikipedie:Pod lípou
Wikipedie:Pod lípou (návrhy)
Wikipedie:Pod lípou (oznámení)
Wikipedie:Pod lípou (práva)
Wikipedie:Pod lípou (pravidla)
Wikipedie:Pod lípou (sesterské projekty)
Wikipedie:Pod lípou (technika)
Wikipedie:Pod lípou (u krbu)
Wikipedie:Pod lípou (Wikimedia ČR)
Wikipedie:Pod reálnou lípou
Wikipedie:Portál Wikipedie
Wikipedie:Potřebuji pomoc
Wikipedie:Povolené zdroje
Wikipedie:Právní kroky a právní výhrůžky
Wikipedie:Průvodce
Wikipedie:Pravidla arbitráže
Wikipedie:Pravidlo tří revertů
Wikipedie:Pravidlo Wikipedie
Wikipedie:Pravidlo Wikipedie#Změny pravidel
Wikipedie:Pravopis
Wikipedie:Revize smazání
Wikipedie:Seznam jazyků Wikipedie
Wikipedie:Správci
Wikipedie:Správci rozhraní
Wikipedie:Třetí názor
Wikipedie:Tipy
Wikipedie:Tiskové zprávy/100000 článků
Wikipedie:URL blacklist
Wikipedie:Velvyslanectví
Wikipedie:Vizuální editor
Wikipedie:Vybraná výročí dne/říjen
Wikipedie:Wikipedie jako zdroj pro média
Wikipedie:WikiProjekt
Wikipedie:WikiProjekty
Wikipedie:WikiProjekt Kvalita/Články k rozšíření
Wikipedie:Zajímavosti
Wikipedie:Zajímavosti/2023
Wikipedie:Zdroje informací
Wikipedie:Zdroje obrázků
Wikislovník:Hlavní strana
Wikiverzita:Hlavní strana
Wikizdroje:Hlavní strana
Wikizprávy:Hlavní strana
Září
Zadní Zvonková
Zaolzie
Země Koruny české
Zemské zřízení Těšínského knížectví
Zima
Zločin




Text je dostupný za podmienok Creative Commons Attribution/Share-Alike License 3.0 Unported; prípadne za ďalších podmienok.
Podrobnejšie informácie nájdete na stránke Podmienky použitia.

Your browser doesn’t support the object tag.

www.astronomia.sk | www.biologia.sk | www.botanika.sk | www.dejiny.sk | www.economy.sk | www.elektrotechnika.sk | www.estetika.sk | www.farmakologia.sk | www.filozofia.sk | Fyzika | www.futurologia.sk | www.genetika.sk | www.chemia.sk | www.lingvistika.sk | www.politologia.sk | www.psychologia.sk | www.sexuologia.sk | www.sociologia.sk | www.veda.sk I www.zoologia.sk